IFS going down for some work

Major incident IFS Scada/Manufacturing systems General Notifications
2022-11-07 23:18 EST · 37 minutes

Updates

Resolved

IFS is back up

November 7, 2022 · 11:56 PM EST
Issue

IFS will be down for 20-30 minutes for some work

November 7, 2022 · 11:21 PM EST

← Back