Maintanence extended

Major incident IFS Scada/Manufacturing systems
2022-11-13 14:33 EST · 44 minutes

Updates

Resolved

IFS is up and operating. Please submit a ticket if you are still having issues

November 13, 2022 · 03:17 PM EST
Issue

It looks like it will take an additional 30-45 minutes

November 13, 2022 · 02:34 PM EST

← Back