IFS is down

Minor incident IFS Scada/Manufacturing systems
2023-01-17 08:35 EST · 40 minutes

Updates

Resolved

IFS is up

January 17, 2023 · 09:15 AM EST
Issue

IFS is down, we are working on it

January 17, 2023 · 08:35 AM EST

← Back