IFS having issues again

Minor incident IFS Scada/Manufacturing systems
2023-01-17 13:56 EST · 10 minutes

Updates

Resolved

IFS is back

January 17, 2023 · 02:06 PM EST
Issue

IFS is again having issues we are working on it

January 17, 2023 · 01:57 PM EST

← Back