IFS is taking longer than expected

Major incident IFS Scada/Manufacturing systems
01-26-2023 08:31 PM EDT · 41 minutes

Updates

Resolved

IFS is back up.

January 26, 2023 · 09:12 PM EDT
Issue

IFS is taking longer than expected. I will notify you as soon as it is working again.

January 26, 2023 · 08:31 PM EDT

← Back