IT Status
Subscribe
to updates
Still working on the IFS issue, should be less than 30 minutes
Major incident
IFS
Scada/Manufacturing systems
01-28-2023 04:18 PM EDT
· 20 minutes
Updates
Resolved
IFS is back up
January 28, 2023 · 04:39 PM EDT
Issue
Still working on the IFS issue should be less than 30 minutes
January 28, 2023 · 04:18 PM EDT
← Back