VPN System is down

Major incident General Notifications Johnstown Värnamo
02-23-2023 07:41 AM EDT · 1 hour, 27 minutes

Updates

Resolved

All systems should now be operating normally

February 23, 2023 · 09:08 AM EDT
Issue

The VPN system appears to be down. This will affect Johnstown, Baltimore, Varnamo and anyone working from home

February 23, 2023 · 07:43 AM EDT

← Back