IFS is down

Minor incident IFS Scada/Manufacturing systems General Notifications
04-02-2023 01:17 PM EDT · 2 hours, 48 minutes, 1 second

Updates

Resolved

IFS is back up. Apologies there was not more notice

April 2, 2023 · 04:05 PM EDT
Issue

IFS is down, this will affect SCADA as well, we are working on it

April 2, 2023 · 01:18 PM EDT

← Back