Internet Issues

Minor incident West Bridgewater
05-02-2023 02:46 PM EDT · 17 hours, 12 minutes

Updates

Resolved

The issues have been resolved. Ascentis and other apps should work now.

May 3, 2023 · 07:58 AM EDT
Issue

We are experiencing issues with our internet. Some apps and websites may be blocked and the internet is generally slower than usual. We are working on resolving this.

May 2, 2023 · 02:46 PM EDT

← Back