IFS down for Maintenance

Minor incident IFS Scada/Manufacturing systems General Notifications Baltimore Drum and Pail Plymouth FPG Plymouth Johnstown Värnamo West Bridgewater
08-07-2023 07:00 PM EDT · 1 hour, 50 minutes

Updates

Resolved

IFS is back up and all systems should be operating normally.

August 7, 2023 · 08:49 PM EDT
Issue

IFS will be down for 90 minutes for maintenance.

August 7, 2023 · 05:07 PM EDT

← Back