IFS coming down at 11

Minor incident IFS Scada/Manufacturing systems General Notifications Baltimore Drum and Pail Plymouth FPG Plymouth Johnstown Värnamo West Bridgewater
09-17-2023 10:49 AM EDT · 2 hours, 51 minutes

Updates

Resolved

Everything should be operating normally

September 17, 2023 · 01:40 PM EDT
Issue

IFS will be coming down at 11am

September 17, 2023 · 10:49 AM EDT

← Back