SCADA Reboot

Minor incident West Bridgewater
03-19-2022 11:49 AM EDT · 15 minutes

Updates

Resolved

Scada is up, please give it a few minutes for any problems to clear

March 19, 2022 · 12:04 PM EDT
Issue

Quick restart of the SCADA system

March 19, 2022 · 11:49 AM EDT

← Back