Ohio Internet is down

Major incident General Notifications Johnstown West Bridgewater
2022-06-14 08:49 EDT · 4 hours, 6 minutes

Updates

Resolved

Ohio Internet is up

June 14, 2022 · 12:55 PM EDT
Issue

Ohio Internet is down. This will effect desk phones/IFS/Scada/Some quality stuff/Cedar Bay etc Spectrum is reporting a general outage in the area

June 14, 2022 · 08:50 AM EDT

← Back