Baltimore Internet is out

Major incident Baltimore
08-05-2022 08:56 AM EDT · 4 hours, 29 minutes

Updates

Resolved

Comcast has fixed the issue and Baltimore is fully operational

August 5, 2022 · 02:08 PM EDT
Issue

Comcast is reporting power outages in the area and that they are working on it

August 5, 2022 · 08:56 AM EDT

← Back