IFS Shutdown for weekend Maintenance

Major incident IFS Scada/Manufacturing systems
08-27-2022 01:00 PM EDT · 2 hours, 16 minutes

Updates

Resolved

IFS is back up

August 27, 2022 · 03:16 PM EDT
Issue

IFS will be down for approximately 90 minutes for weekend Maintenance

August 27, 2022 · 10:19 AM EDT

← Back