IT Status
Subscribe
to updates
IFS Shutdown at 1pm
Major incident
IFS
Scada/Manufacturing systems
General Notifications
08-27-2022 01:00 PM EDT
· 1 hour, 30 minutes
Updates
Update
Reminder IFS is down for Maintenance
August 27, 2022 · 01:00 PM EDT
Issue
The IFS shutdown is scheduled for 1pm
August 27, 2022 · 10:25 AM EDT
← Back